First image in folder is sometimes corrupted

Home Forums RAW Power for macOS General Discussion First image in folder is sometimes corrupted

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #129123

    Hi Nik,

    It’s that time of year where I put my calendar together and brush off the cob webs of my photo workflow.

    This year I ran into a weird problem when using Raw Power with a File Browser window. Once in a while, I notice that the thumbnail for the first file in the folder appears corrupted. This did not occur for every folder I had open in the browser. Initially, the image did not load properly into the viewer either which suggested a corrupt file. Moreover, when I attempted to load the images with Preview, they appeared corrupted as well (similar to the thumbnail image). Interestingly, if I open the images with Pixelmator, the image appears corrupted as well. However, if I open the image with Affinity Photo, it displays fine. Even more interesting, if I click the images in RP after opening them with Affinity Photo (I did not “develop” the raw photos in AP, I cancelled the develop and quit AP), the images load into the RP viewer though the thumbnail is still appears corrupted. And Preview loads the image properly now as well.


    RP 3.4.11
    macOS 13.0.1
    M1 Max MBP
    AP 1.10.5
    Pixelmator 3.9.11

    Nik Bhatt

    That’s definitely strange, though some of it is explainable. Affinity doesn’t use Apple’s RAW, while Preview, Pixelmator, and RAW Power all do. So the corruption part is at least consistent. I cannot begin to guess why opening the photo in Affinity fixes the corruption problem.


    I have noticed corruption at other times as well. I started editing an image, then clicked another image before clicking “done”, realized I had done that and clicked back to the original image. I clicked “done” and then went to the second image but now the second image loads almost entirely black. In this case, the thumbnail is fine and the image is the corrupted element. I am thinking this is some sort of problem with Apple Raw processing … maybe some kind of race condition and the “working copy” of the image or thumbnail gets messed up.


    Interesting observation, when I click from a “good” image to the “suspect” image, I see the image appear in the viewer briefly, and then it goes completely black. When I opened the file in Preview, is briefly showed the entire image and then about 90% of the image went black.

    As reported earlier, if I open the image with Affinity Photo and then close Affinity Photo without developing or otherwise editing the image … I can click on the image in Raw Power and it is not all black anymore. Similarly, I can open it in Preview fine now as well. I surmise Apple Raw is creating a temporary working image and somehow that is what is being corrupted. Somehow, opening the image with Affinity Photo causes the temporary file to be invalidated or otherwise discarded by Apple Raw.



    I wonder if this is similar to the issue I reported a while back, but on iPadOS (it’s not happened on my iMac, using any kind of MacOS). I’ve also been seeing corrupt previews while in editing mode. It’s occurring slightly differently for me, but essentially I’m resulting in a corrupt view where I cannot edit the image at all (even the histogram reflects what’s displayed on screen).

    I originally started off with it being the first image I edited being corrupt (probably about 18 months ago). If I clicked on another image, then back to the original, it cleared the issue.

    In the last year or more though it developed further, so that it appears only after I’ve edited a few images (6-10 perhaps). Once it starts though, it happens on probably every other image. Clicking on another, then back again can clear it, but it can take a few goes before it does. It’s not related to file type, or image size either, as it happens on a variety of Raw images from different eras (Nikon, Fuji and Olympus in use here).

    Here I’m using a 2020 iPad Pro 12.9″, and this has certainly been happening on the last two iPaOS versions. I’m using it with the Photos iCloud based library, so it might suggest there’s something going on with that.

    I haven’t tried the opening in another app trick though, but if I use any other app, I never see this issue elsewhere.

    (BTW, this isn’t meant to be a moan, just trying to add some info, in case it’s useful).

    Cheers, and season’s greetings.


    @thewildrover, interesting. I recall that occurring in earlier versions for me. Clicking another photo and coming back always seemed to fix the issue so I never really thought much about it. I will add my images typically come from a Nikon (D7000) but from time to time I also edit iPhone images as well. And, I am using the File Browser to avoid being messed up by Apple (ie: Aperture mess).

    On a side note, it would be wonderful if the File Browser could be integrated with the Photo Library.


    @thewildrover I read through your forum thread here:

    I believe my problem is similar to what you reported with the exception that I am experiencing this on a Mac. The corruption manifests as a totally blank preview or image, partially blank image or preview or as a “psychedelic” preview or image from time to time as well.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.