“Raw Processing” issues when pasting edits

Home Forums RAW Power Help Forum “Raw Processing” issues when pasting edits

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #82707

    Hi there

    I’ve noticed a repeating issue where the “Raw Processing” tick box and associated settings completely breaks and can only be “fixed” again with multiple back and force edit reverts and other fiddling.

    Step 1: edit an image and copy the settings (Cmd-C)
    Step 2: paste the settings onto a photo that does not have “RAW Processing” ticked

    Result: “RAW Processing” steps are not applied and the “RAW Processing” section ceases to function.

    Alternatively, this works, but is a hassle and I often forget:
    Step 1: edit an image and copy the settings (Cmd-C)
    Step 1.5: tick “RAW Processing” in target image
    Step 2: paste the settings onto target photo

    The worst part is that I can’t even batch apply the ‘tick “Raw Processing”‘ step because that piece never applied!

    To fix this takes a lot of fiddling and I’ve not found a fool-proof method, but I need to revert the image, navigate away for a while and then hope that the feature works again when I return.

    This is a complete show stopping bug for me and a disappointing introduction to the software. Is there some trick that I’ve missed, or am I doing something fundamentally wrong?

    Nik Bhatt


    I’m sorry you are encountering issues copying and pasting adjustments. I tried the steps that you listed, but I cannot seem to reproduce the problem. Here is a link to a video that I made: https://www.dropbox.com/t/0YGKECOICyEBwF6M

    If you don’t mind, please check that out (and maybe do the same steps to see if that works). If you can also make a video for me, I can try those steps as well. You can post a link here, or email support@gentlemencoders.com.




    Obviously as soon as I set up screen recording I can’t recreate the issue…

    I will revive this thread if I’m able to make it happen again!

    Working is good though, thanks for responding. Hopefully the issue never returns 🙂


    Ok, did another paste job across multiple photos and issue is back. I’ve emailed you a video showing what the resulting issue is, and how reverting the image in Photos.app is needed to restore the Raw Processing functionality. Hopefully it helps identify the cause and a resolution!

    Nik Bhatt

    Thanks for sending me the video – the problem appears to be specific to RAW+JPEG pairs, which your video pointed out to me.

    This is what I have determined. The following does not work:

    Edit an R+J image
    Copy Adjustments
    Paste onto another R+J image (by right-clicking on it)

    This works for me:
    Edit an R+J Image
    Copy Adjustments
    Click on another R+J image so you enter Edit
    Paste adjustments.

    Here is a link to a video showing the two approaches: https://www.dropbox.com/t/deoT6dOoIuEebJsE

    I’ll work on a fix for the next release. Sorry about the bug.



    Your workaround explains why it appeared to work when I pre-ticked the Raw Processing it worked, because I had done the necessary ‘click edit’ step.

    Thanks for looking into this.

    While we’re here, is it expected behaviour that most raw processing options are not enabled for DNG files?

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.